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General Ledger 
When is the GL Monthly Close? 
The GL monthly close is on the 5th business day of the month at 9 AM.   
All journals should be created and in the General Ledger by 9 AM.   
If using the GL-PCR or sending a GL feed, the deadline for submission is 4:30 PM on the 4th business day.   
The 5th business day does not process GL-PCR or GL feeds until after the GL close is complete due to the GL feed 
processing is halted on days in which COA disables occur (The exception is on quarter closes since COA disables are not 
done until the 10 business day.  But, the submission deadline remains the same to allow for processing time.) 
 
Why does the accounting period stay open sometimes after the GL monthly close 5th business day? 
Each quarter, the GL period remains open until the 10th business day for central accounting activities.   
If a tub needs a journal posted during that time, they need to go thru the central accounting office. 
Additionally, each fiscal year end the June accounting period remains open for a while due to year-end activities.   
See the Enews for fiscal year end details. 
 
After a journal is submitted can changes still be made to it? 
Users have until 6:30 PM to make changes to manual, recurring, autocopy, reversed or ADI journals. 
 
If a journal is created in Oracle on a weekend or holiday, when will it show in reporting? 
Any journal added after 6:30 PM on Friday will not be posted until 6:30 PM on the next business day (usually Monday).   
It would show in the Harvard Data Warehouse (HDW) reporting on the following morning (usually Tuesday). 
The exception to this rule is fiscal year end where specials processing and load runs are added on a couple of Sunday 
nights; then it will show in the HDW on Monday.  The exact dates change around each year,  but typically is the 
weekends between 1st and 2nd June close, and 2nd and 3rd June close. 
 
How many characters are allowed in manual journal Batch Name? 
100 characters total with spaces and with the create date and time stamp (80 batch name, 20 date and time) 
 
What is object code 0375? 
Object code 0375 “Due to/Due from” represents a Tub’s working capital.  Since most cash isn’t on a Tub’s balance sheet, 
the activity in this account represents the inflows of revenues/cash items (receivables collected, funds transferred, Misc. 
income collected, etc.) and outflows of expense/cash items (invoice payments, salary payments, etc.). 
 
What is a DFF? 
The Descriptive Flex Field (DFF) is required for journals that contain certain object codes.  The purpose of the DFF is to 
provide more information about the journal line.  The more information given at the time of input reduces the possibility 
of questions from auditors or co-workers.  For a complete list of object codes that require the DFF, refer to the 
document ‘DFF_Object Codes and DFF Requirements’.   
 
Naming Convention - some people use the ^ as a separator,  why and is it required? 
The caret ^ separator is used to indicate space, since it is difficult to tell if there is one space or two spaces in a Name / 
Description. It is not required to be used.  
 

https://admin-enews.eureka.harvard.edu/home
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My computer does not have Java JRE on it.  Is it needed? 
The Oracle General Ledger forms need the Java JRE.  Please see information on the Java JRE version here. 
But WebADI and GL-PCR do not use the Java JRE. 
 
I cannot launch Oracle forms.  How do I get into the GL? 
Try one of these and then try Oracle forms again: 

• Clear your web browser’s cashe.  Ctrl-Shift-Delete will bring the cashe up on any web browser. 
• Try a different web browser. 
• Check that your Java JRE is enabled.  Go into the Java Control Panel under the Security tab and clicked the box to 

"Enable Java content for browser and Web Start applications”. 
 
Application Desktop Integrator (ADI) 
 
Microsoft Visual Basic Run-time Error ‘1004’ 
This is an MS Excel setting which needs to be adjusted. 
1. Open Excel 
2. On the Menu bar go to File, then [Excel] Options, then Trust Center, then Trust Center Settings, then Macro Settings 
3. In the top section, select the radio button for “Disable all macros with notification”. 
4. In the bottom section, check the box for “Trust access to VBA project object model”. 
5. Click OK to save the settings.  
6. Close Excel. 
7. In the spreadsheet which is being created, Excel will then ask if the Macros should be allowed to run. 
8. Only enable macros from trusted sources. 
 
When opening a WebADI worksheet, the process “hangs” on the Processing: Create Document screen. 
To add *.harvard.edu as a trusted site: 
Search for Control Panel, open Control Panel > Internet Options > Security tab > click on the Trusted sites icon > click the 
“Sites” button > Uncheck the box “Require server verification (https:) for all sites in this zone” Then, click in the first box, 
which reads “Add this Web site to the zone:” > Type *.harvard.edu > Click Add, The line should drop from the top box to 
the bottom box. > Recheck the box “Require server verification (https:) for all sites in this zone” > Click Close > Click OK.   
 
Getting the error “ADI connection unavailable” or “Action Required Your login session is no longer valid…” 
These are basic error messages saying that the macros are not connecting to the Oracle database. 

- Close Excel, then go into Oracle and generate a new ADI worksheet, then click on the white field next to the 
Journal Category. 
If a pop up occurs, the worksheet is connecting.  
If using a saved worksheet, open it next and try getting the Journal Category to pop up on that worksheet.  If it 
comes up, upload your worksheet from there. 
If it does not come up, please copy the lines to the recently generated worksheet which does get the pop up and 
upload from the new worksheet. 

- Sometimes clearing your web browsers cashe (Ctrl-Shift-Delete) takes care of the issue, then try ADI again. 
 

https://oracle.fss.finance.harvard.edu/supported-desktop-configurations-oracle-ebs-financial-systems
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When opening a WebADI worksheet, Excel notes a Security Risk Microsoft has blocked macros from running 
because the source of this file is untrusted. 

 
The latest version of Microsoft (MS) Office has added security. It is, therefore, necessary to add the download / working 
path to trusted locations and save the webadi files there before opening. 

 To implement the solution, please follow the steps below :  
1)  Open any blank MS Excel worksheet  
2)  Navigate to File > Options > Trust Center > Trust Center settings > Trusted locations  
3)  Click on "Add locations" button and add the appropriate path where the WebADI document is  
      downloaded / saved.  Please note at times ADI has issues with uploading journals from share drives because 
      of the long path names. If your ADI is on a share drive, you may want to try adding your desktop to upload 
      from instead. 
4)  Click "Ok"  
5)  Re-test the issue by downloading new WebADI document 

Alternatively, users can unblock a single document at a time.  The user will be able to go to the Properties dialog 
for the file and select Unblock which will allow the macros to run, as long as no policy or Trust Center setting is 
blocking. 

 
My computer does not have Java JRE on it. 
ADI does not use the Java JRE. 
 
How do I unprotect the WebADI worksheet? 
While in your ADI Excel spreadsheet go to Review > Unprotect Sheet.  There is no associated password 
 
After inserting lines and uploading there are no smiley faces on those lines 
This usually occurs when rows are inserted near the top or bottom of the data lines area.  Somehow the line macros do 
not exist on those rows.  The user should instead insert the rows in the middle of the white data lines area.  Copy and 
paste the data to the new lines and deleted the lines which do not have the macros on them. 
 
Can I use formulas in my WebADI worksheet? 
It is best if formulas are used outside of the ADI white colored data fields – best spots are on a new tab or to the right of 
the template, then do a copy-paste special-values into data fields.  
Although it is not recommended, many users do add macros in the white colored data fields and have no issues.  Of 
course, users should be checking/matching their dollars amount and line count after each upload via the output file to 
ensure that what they have on their worksheet is what was imported to the GL. 
 
ADI:  How many characters are allowed in Batch Name, Batch Description, Journal Name, Journal Description? 
The Batch Name allows 94 characters with spaces and with Request ID Number.  See additional information below. 
The Batch Description truly brings over the 240 characters. 
The Journal Name truly brings over the 100 characters.  See additional information below. 
The Journal Description truly brings over the 240 characters. 
 
In reviewing the Batch Name for ADI spreadsheets, it is made up of: 
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  User’s batch name, the Journal Source, A (for Actuals), Group ID, Request ID number. 
If the user put a long Batch Name, the Request ID number stays always. 
  But the group ID is the first to get cut, then the “A” gets cut, then the Journal Source, then the user’s batch name 

• Batch Name                       65 
• Space                                    1 
• Journal Source                  11 
• Space                                    1 
• A for Actuals                      1 
• Space                                    1 
• Group ID                              5 
• Space                                    1 
• Request ID                          8 

 
Total                                              94            

 
If the Journal Name is less than 100 characters, the system appends the Journal Category then the Currency code.  For 
Example: sdo test for lines Adjustment USD 
 
ADI DFF question:  I think am still not clear on when I need 6 periods instead of 5 at the DFF field.  
For example, see the two strings below, one posted with 6 and the other with 5.  
Pyrl Bi Weekly.12-JUN-2013.6050.12345678.Harvard, John.. 
Pyrl Bi Weekly.12-JUN-2013.6052.12345678.Harvard, John. 
 
Please note payroll journals are now completed using GL-PCR but there are some cases where an ADI is used. 
Each object code can be assigned additional fields to provide more information about the transaction. 
For object code 6050, the extra fields assigned are: 
  Originating Journal Name (this is a global dff – it appears on all object codes) 
  Originating Journal Date  (this is a global dff – it appears on all object codes) 
  Harvard ID (required) 
  Employee Name (required) 
  Fringe By Pass 
  Period of Work Performed 
 
For object code 6052, the extra fields assigned are: 
  Originating Journal Name (this is a global dff – it appears on all object codes) 
  Originating Journal Date  (this is a global dff – it appears on all object codes) 
  Harvard ID (required) 
  Employee Name (required) 
  Fringe By Pass 
 
Each field is separated by a delimited.  Oracle uses the period as their delimiter. 
The fields are put into ADI concatenated together using the delimiter in between.  The global DFFs are first, then the 
object code, then the additional dffs. 
 
So if all the fields for 6050 the dff information are filled in, it looks like this: 
  Originating Journal Name.Originating Journal Date.6050. Harvard ID. Employee Name.Fringe By Pass.Period of Work 
Performed 
If any of the non-required fields are not filled in, 6050 dff would look like this: 
  ..6050. Harvard ID. Employee Name.. 
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Likewise, if all the fields for 6052 the dff information are filled in, it looks like this:   
  Originating Journal Name.Originating Journal Date.6052. Harvard ID. Employee Name.Fringe By Pass 
If any of the non-required fields are not filled in, 6052 dff would look like this: 
  ..6052. Harvard ID. Employee Name. 
 
The fields always need to be recognized with the delimiter even if you do not fill them in. 
 
How do I add a period for a user’s middle initial in the Employee Name DFF? 
Oracle systems will retain a period if a backslash is added before.  See example below for Lauder, George V. 

 
 
When going to the path Add Ins > Oracle only Filters and List of Values show, the Upload option is missing 
Typically, the cause of this is too many characters (more than 10) for the folder name.   
Some users save their ADI worksheet on a share drive then upload it from that location.   
The solution is to save the ADI file to a local folder such as the desktop and open the file and upload it from there. 
 
On the menu bar, my “Add Ins” tab is missing 

- Generate a new ADI worksheet and enable the macros.   
- In 12.2 the “Add Ins” menu bar has been replaced by the “Oracle” menu bar 
- For a new computer, check that the Excel Options > Add Ins have Analysis ToolPak and Analysis ToolPak-VBA 

 
WebADI Error: org.apache.poi.openxml4j.exceptions.InvalidFormatException: Package should contain a content type part [M1.13] 
When uploading an ADI worksheet an error appears.  There is no space/memory available in the user's Temp directory 
to perform upload processing.  The issue can be resolved by deleting the old files from the user's 
C:\Users\XXXX1234\AppData\Local\Temp directory, making sure to include the old bnerad% files.  User should do a 
restart of their computer then try ADI again. 
 
WebADI Excel Error "Cannot run the macro HsTbar.xla!HsTbarAction'. The macro may not be available in this workbook or all 
macros may be disabled" 
The user is clicking on the "Add Ins" menu instead of clicking on the "Oracle" menu for upload.  Click on the Oracle menu 
bar item then Upload.. 
 
WebADI Error: Microsoft Visual Basic Runtime Error '5'. 
This usually occurs when an ADI spreadsheet has had additional macros added.  Unfortunately, ADI spreadsheets in 
which macros have been added or altered are not supported by Oracle Application.  Please refer back to the source of 
the altered spreadsheet for assistance. 
 
WebADI Error: -2147417848 SystemId 
When creating an ADI worksheet an error appears, The object invoked has disconnected from its clients.  Error: -
2147417848 SystemId:  The issue can be resolved by reformatting the computer. 
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