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General Ledger 
GL: When is the GL Monthly Close? 
The General Ledger (GL) monthly close is on the 5th business day of the month at 9 AM.  All journals should be in the 
General Ledger by 9 AM.  If using the GL-PCR or sending a GL feed, the deadline for submission is 4:30 PM on the 4th 
business day (to allow for processing time).  The 5th business day does not process GL-PCR or GL feeds until after the GL 
close is complete in order for the COA Disables to run, which is part of the GL close.   
The exception is quarter closes (SEP, DEC, MAR) since COA Disables are not done until the 10th business day.  But the 
submission deadlines remain the same.  On quarter closes (SEP, DEC, MAR) the 5th business day does not stop processing 
GL-PCR or GL feeds, but journals for the closing month will not be posted after 9 AM.  For quarter closes (SEP, DEC, MAR) 
on the 10th business day, the GL feed processing is held until after the COA Disables run, which is part of the GL close.    
 
GL: Why does the accounting period stay open sometimes after the GL monthly close 5th business day? 
Each quarter (SEP, DEC, MAR), the GL period remains open until the 10th business day for central accounting activities.   
If a Tub needs a journal posted during that time, they need to go through the central accounting office.  User should not 
add journals themselves to the closing accounting period after 9 AM on the 5th business day. 
Additionally, each fiscal year end the June accounting period remains open for a while due to year-end activities.   
See the Enews for fiscal year end details. 
 
GL: After a journal is submitted can changes still be made to it? 
Users have until 6:30 PM to make changes to manual, recurring, autocopy, reversed or ADI journals. 
 
GL: If a journal is created in Oracle on a weekend or holiday, when will it show in reporting? 
Any journal added after 6:30 PM on Friday will not be posted until 6:30 PM on the next business day (usually Monday).   
It would show in the Harvard Data Warehouse (HDW) reporting on the following morning (usually Tuesday). 
The exception to this rule is fiscal year end where specials processing and load runs are added on a couple of Sunday 
nights; then it will show in the HDW on Monday.  The exact dates change around each year,  but typically is the 
weekends between 1st and 2nd June close, and 2nd and 3rd June close. See the Enews for fiscal year end details. 
 
GL: How many characters are allowed in manual journal Batch Name? 
100 characters total with spaces and with the create date and time stamp (80 batch name, 20 date and time) 
 
GL: What is object code 0375? 
Object code 0375 “Due to/Due from” represents a Tub’s working capital.  Since most cash isn’t on a Tub’s balance sheet, 
the activity in this account represents the inflows of revenues/cash items (receivables collected, funds transferred, Misc. 
income collected, etc.) and outflows of expense/cash items (invoice payments, salary payments, etc.). 
 
GL: What is a journal DFF? 
The Descriptive Flex Field (DFF) is required for journals that contain certain object codes.  The purpose of the DFF is to 
provide more information about the journal line.  The more information given at the time of input reduces the possibility 
of questions from auditors or co-workers.  For a complete list of object codes that require the DFF, refer to the 
document Object Codes and Associated DFFs.   
 

https://admin-enews.eureka.harvard.edu/home
https://admin-enews.eureka.harvard.edu/home
https://oracle.fss.finance.harvard.edu/general-ledger-user-guide
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GL: Naming Convention - some people use the ^ as a separator,  why and is it required? 
The caret ^ separator is used to indicate space, since it is difficult to tell if there is one space or two spaces  
in a Name / Description.  It is not required to be used.  
 
GL: My computer does not have Java JRE on it.  Is it needed? 
The Oracle General Ledger forms need the Java JRE.  Please see information on the Java JRE version here. 
Please note, WebADI and GL-PCR do not use the Java JRE. 
 
GL: I cannot launch Oracle forms.  How do I get into the GL? 
Try one of these and then try Oracle forms again: 

• Clear your web browser’s cashe.  Ctrl-Shift-Delete will bring the cashe up on any web browser. 
• Try a different web browser. 
• Check that your Java JRE is enabled.  Go into the Java Control Panel under the Security tab and clicked the box to 

"Enable Java content for browser and Web Start applications”. 
 
GL: When logging into Oracle, error message “Missing Security Attributes” or “Bad Request”? 
To fix these issues, please follow these instructions: 

• Close Excel and all web browsers. 
• Go to your Windows Control Panel > Internet Options > (Tab) General > Delete… > Check all boxes > Delete > 

Apply > OK 
• Also in the Windows Control Panel > Java > Temporary Internet Files > Settings… > Delete Files… > Check boxes 

for “Trace and Log Files”, “Cached Applications and Applets” > OK > OK > OK 
• Open the web browser you like to use (Chrome, Edge, or Firefox ESR) to delete cookies and cache: Ctrl-Shift-Del 

> must choose “Everything”/“All Time” range > Clear Data/ Clear Now 
• Close the web browser, at this point you should be able to log in as normal 

 
GL: While attempting to View Output of a concurrent request in Oracle, "authentication failed" message? 
So far this has occurred only in the MS Edge web browser.  To resolve:  Open MS Edge and click on the three horizontal 
dots in the upper right hand corner.  On the resulting menu which opens, click on Settings.  On the Settings screen, click 
on Downloads on the left side, then on the right side of the screen, toggle off "Open Office files in the browser" (the 
toggle dot will move to the left).  Close MS Edge.  Re-open MS Edge and navigate back to opening the Output file, it 
should now be allowed to be viewed. 
 
 
Application Desktop Integrator (ADI) 
 
ADI: Microsoft Visual Basic Run-time Error ‘1004’ 
This is an MS Excel setting which needs to be adjusted. 

• Open Excel 
• On the Menu bar > File > [Excel] Options > Trust Center > Trust Center Settings > Macro Settings 
• In the top section, select the radio button for “Disable all macros with notification”. 
• In the bottom section, check the box for “Trust access to VBA project object model”. 
• Click OK to save the settings.  Close Excel. 
• When generating a new spreadsheet, Excel will ask if the Macros should be allowed to run. 
• Only enable macros from trusted sources. 

https://oracle.fss.finance.harvard.edu/supported-desktop-configurations-oracle-ebs-financial-systems
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ADI: When opening a WebADI worksheet, the process “hangs” on Processing: Create Document. 
To resolve this issue, add  *.harvard.edu as a trusted site: 

On your Windows computer, open the Control Panel > Internet Options > Security tab > click on the Trusted sites 
icon > click the “Sites” button > Uncheck the box “Require server verification (https:) for all sites in this zone” Then, 
click in the first box, which reads “Add this Web site to the zone:” > Type *.harvard.edu > Click Add, The line should 
drop from the top box to the bottom box > Recheck the box “Require server verification (https:) for all sites in this 
zone” > Click Close > Click OK.   

ADI: Error “ADI connection unavailable” or “Action Required Your login session is no longer valid…” 
These are basic error messages saying that the macros are not connecting to the Oracle database. 

Close Excel.  Generate a new ADI spreadsheet from Oracle Financials.  On the Oracle Menu Bar, click on "Switch 
Responsibility", choose your appropriate General Ledger responsibility, click "Select" then click "Close".  Open your 
previously saved ADI worksheet or fill out the current ADI worksheet to upload. 

ADI: Error in Excel, Security Risk “Microsoft has blocked macros…this file is untrusted.” 

 
The latest version of Microsoft (MS) Office has added security. It is, therefore, necessary to add the download / working 
path to trusted locations and save the webadi files there before opening. 
To implement the solution, please follow the steps below:  

1)  Open MS Excel > New > Blank workbook 
2)  Navigate to File > Options > Trust Center > Trust Center Settings… > Trusted Locations  
3)  Click on "Add new location…" button and add the appropriate path where the WebADI document is  
      downloaded / saved.  Please note at times ADI has issues with uploading journals from share drives because 
      of the long path names. If your ADI is on a share drive, you may want to try adding your desktop or  
      downloads folder to upload from instead. 
4)  Click "OK" to add the new location and “OK”, “OK” to exit the screens. 
5)  Re-test the issue by downloading new WebADI document 

Alternatively, users can unblock a single document at a time.  The user should go to the Properties dialog for the file and 
select Unblock which will allow the macros to run, as long as no policy or Trust Center setting is blocking. 
 
ADI: My computer does not have Java JRE on it. 
ADI does not use the Java JRE. 
 
ADI: For the path Add Ins > Oracle only Filters and List of Values show, the Upload option is missing 
Typically, the cause of this is too many characters (more than 10) for the folder name.   
Some users save their ADI worksheet on a share drive then upload it from that location.   
The solution is to save the ADI file to a local folder such as the desktop and open the file and upload it from there. 
 
ADI: On the menu bar, my “Add Ins” tab is missing 

- Since the Oracle 12.2 upgrade, the “Add Ins” menu bar has been replaced by the “Oracle” menu bar 
- Generate a new ADI worksheet and enable the macros.   
- For a new computer, check that the Excel Options > Add Ins have “Analysis ToolPak” and “Analysis ToolPak-VBA” 
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ADI:  Uploading Error org.apache.poi.openxml4j.exceptions.InvalidFormatException:  
   Package should contain a content type part [M1.13] 
When uploading an ADI worksheet an error appears.  There is no space/memory available in the user's Temp directory 
to perform upload processing.  The issue can be resolved by deleting the old files from the user's 
C:\Users\XXXxxx\AppData\Local\Temp directory, making sure to include the old bnerad% files.  Users should do a restart 
of their computer then try ADI again.  If that does not work, a desktop support had success by “creating a new local 
admin account on the computer” (desktop support should assist). 
 
ADI:  Excel Error "Cannot run the macro HsTbar.xla!HsTbarAction'. 
   The macro may not be available in this workbook or all macros may be disabled" 
The user is clicking on the "Add Ins" menu instead of clicking on the "Oracle" menu for upload.  Since the Oracle 12.2 
upgrade, the “Add Ins” menu bar has been replaced by the “Oracle” menu bar.  Previously saved old worksheets may 
still show the old path.   The user should generate and use a new ADI worksheet and then on the menu bar click Oracle > 
Upload.   
 
ADI:  Error Microsoft Visual Basic Runtime Error '5'. 
This usually occurs when additional macros are added to an ADI spreadsheet.  Unfortunately, ADI spreadsheets in which 
macros have been added or altered are not supported by Oracle Application.  Please refer back to the source of the 
altered spreadsheet for assistance.  Alternatively, users may be able to generate a new ADI worksheet and copy/paste 
special, values the information into it. 
 
ADI:  Error -2147417848 SystemId 
When creating an ADI worksheet an error appears: The object invoked has disconnected from its clients.  Error: -
2147417848 SystemId:  The issue can be resolved by reformatting the computer. 
 
ADI: Error The specified directory C:Users\xxxXXX\AppData\Local\...docProps is empty,  
   Error:  The specified directory C:Users\xxxXXX\AppData\Local\Temp\bneradCBBD0\bne\docProps is empty, so Compressed 
(zipped) Folders cannot add it to the archive. 
Delete all files from your version of this location C:\Users\xxxXXX\AppData\Local\Temp 
What I usually do is highlight everything and delete them – the system will tell you if any files are in use – for those I say 
to not delete them.  Restart your computer, then try WebADI again. 
 
ADI: How do I unprotect the WebADI worksheet? 
While in your ADI Excel spreadsheet go to Review > Unprotect Sheet.  There is no associated password 
 
ADI: After inserting rows and uploading there are no smiley or unhappy faces on those rows 
This usually occurs when rows are inserted near the top or bottom of the data lines area.  Somehow the line macros do 
not exist on those rows.  The user should instead insert the rows in the middle of the white data lines area.  Copy and 
paste the data to the new lines and delete the lines which do not have the macros on them. 
 
ADI: Can I use formulas in my WebADI worksheet? 
It is a best practice if formulas are used outside of the ADI data fields (usually these fields have a white background).  
The best locations for formulas are on a new tab or to the right of the template, after the “Messages” column.  Users 
then can do a copy/paste special, values into the data fields.  
Although it is not recommended, many users do add macros in the ADI data fields and have no issues.  Of course, users 
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should be checking/matching their dollars amount and line count after each upload using the output file of the ADI 
journal import to ensure that what they have on their worksheet is what was imported to the GL. 
 
ADI:  How many characters are allowed in Batch Name, Batch Desc, Journal Name, Journal Desc? 
The Batch Name allows 94 characters with spaces and with the Request ID Number.   

The Batch Name for ADI spreadsheets, it is made up of: 
  User’s batch name, the Journal Source, A (for Actuals), Group ID, Request ID number. 
If the user put a long Batch Name, the Request ID number always stays.  But the Group ID is the first to 
get cut, then the “A” gets cut, then the Journal Source, then the user’s batch name.   
This is an example of the spacing: 

Batch Name                       65 
Space                                     1 
Journal Source                   11 
Space                                     1 
“A” for Actuals                     1 
Space                                     1 
Group ID     (varies)             5 
Space                                     1 
Request ID                            8 

 
Total                                     94            

The Batch Description allows 240 characters. 
The Journal Name allows 100 characters.  If the Journal Name is less than 100 characters, the system appends the 

Journal Category then the Currency code.  For Example: sdo test for lines Adjustment USD 
The Journal Description allows 240 characters. 
 
ADI: DFF question - I think am still not clear on when I need 6 periods instead of 5 in the DFF field.  
For example, see the two strings below, one has 6 periods in it, and the other has 5 periods.  

Pyrl Bi Weekly.12-JUN-2013.6050.12345678.Harvard, John.. 
Pyrl Bi Weekly.12-JUN-2013.6052.12345678.Harvard, John. 

Please note payroll journals are now completed using GL-PCR, but there are some cases where an ADI is being used. 
 

Each object code can be assigned DFFs (descriptive flexfields) to provide more information about the transaction. 
For example, object code 6050, the extra fields assigned are: 
  Originating Journal Name (this is a global dff – it appears on all object codes) 
  Originating Journal Date  (this is a global dff – it appears on all object codes) 
  Harvard ID (required) 
  Employee Name (required) 
  Fringe By Pass 
  Period of Work Performed 
 
For object code 6052, the extra fields assigned are: 
  Originating Journal Name (this is a global dff – it appears on all object codes) 
  Originating Journal Date  (this is a global dff – it appears on all object codes) 
  Harvard ID (required) 
  Employee Name (required) 
  Fringe By Pass 
 
Each field is separated by a delimited.  Oracle uses the period as their delimiter. 
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The fields are put into ADI concatenated together using the delimiter in between.  The global DFFs are first, then the 
object code, then the additional dffs. 
 
So if all the fields for 6050 the dff information are filled in, it looks like this: 
  Originating Journal Name.Originating Journal Date.6050. Harvard ID. Employee Name.Fringe By Pass.Period of Work 
Performed 
If any of the non-required fields are not filled in, 6050 dff would look like this: 
  ..6050. Harvard ID. Employee Name.. 
 
Likewise, if all the fields for 6052 the dff information are filled in, it looks like this:   
  Originating Journal Name.Originating Journal Date.6052. Harvard ID. Employee Name.Fringe By Pass 
If any of the non-required fields are not filled in, 6052 dff would look like this: 
  ..6052. Harvard ID. Employee Name. 
 
The fields always need to be recognized with the delimiter even if you do not fill them in. 

 
ADI: How do I add a period for a person’s middle initial in the Employee Name DFF? 
Oracle systems will retain a period if a backslash is added before.  See example below for Lauder, George V. 

 
Please note payroll journals are now completed using GL-PCR, but there are some cases where an ADI is being used. 
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