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Define Recurring Journal

Purpose

Use this procedure to define a recurring journal template that can be used to create a General Ledger
(GL) journal in a chosen period with the same information in it each time.

Trigger

A journal entry needs to be created frequently with the same or similar information in it.

Prerequisites

The journal header and line information for the frequently occurring journal must be available.
The user should understand how to create a journal in the General Ledger and have access to an
Oracle Harvard GL responsibility (HRVDAGLA...).

Navigator Path

Journals > Define > Recurring
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Define a Recurring Journal Formula

1. Loginto Oracle and using a HRVDAGL"... responsibility, select Journals > Define > Recurring

Home

4 [0 HRVDAGLA
[E Reports
[E Enter
[E Mew Joumnal
[E Encumbrances
[E Allocations
|J HUGL - Journal Adjustment

[& Allocation

» Bm Generate
b B3 Other

2. This will open the Define Recurring Journal Formula form:

© Define Recurring Journal Formula (HARVARD UNIVERSITY) 5 [= &3

Recurring Batch

Last Executed
Batch

Period
D
escription Date
Recurring Batch Type | Single Ledger -
Ledger HARVARD UNIVERSITY
AutoCopy...
["| Enable Security [ 1
Journal Entry
Effective Dates
Journal
From
Led
edger o
Category
Currency Conversion Type 1
Generate

3. Complete the following fields in the Recurring Batch region to set up the batch header:
Batch (name) and Description

Field Required/Optional/ |Data
Conditional (R/0/C)
Batch Required Add Tub and User initials and description
Character limit is 30
Example: CADM KSG Test 1
Description Optional Add a description of the batch
Character limit is 60 before saving; 240 after
saving

1 Fields with yellow backgrounds are required; white backgrounds are not required
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4. Complete the following fields in the Journal Entry region to set up the journal header:

Recurring Batch

Batch |CADM KSG Test 1
Description This is a test
Recurring Batch Type | Single Ledger
Ledger HARVARD UNIVERSITY
[ Enable Security

=lox|

Last Executed
Period
Date

AutoCopy...
[

Field R/0O/C Data
Journal Required Add Tub and User initials and description
Character limit is 30
Example: CADM KSG Testing journal
Category Required Appropriate accounting category

Recurring Batch
Batch |CADM KSG Test 1
Description |This is a test

Recurring Batch Type | Single Ledger

Last Executed
Period
Date

Ledger |HARVARD UNIVERSITY

[ Enable Security

Journal Entry

Journal |CADM KSG Testin

Ledger |HARVARD UNIVERSITY

Category |Adjustment
Currency |USD

AutoCopy...

Effective Dates
g journal
From

To

Caonversion Type [

Lines

Generate

1. When selecting Category, a list of values is available using the ... button:

Categories

Find|%

Category
Addition

Aid

Allocation
Application Fee
Asset Disposition
Auto JV Rvrsl|

BOE

BR Bank Transfer
Balance Forward
Balance Sheet Close
Bank Charges

Bank Receipts
Al

Adjustment .

»

Eind | 0K Cancel |
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5. OPTIONAL: If only using the recurring journal for a certain time period, fill out the Journal
Entry Effective Dates. Select the From and To fields and click on the ... button, this will pop up a
calendar to select a date. When effective dates are added to the recurring journal set up, the

recurring journal can only be generated during these dates. Effective dates can be adjusted.

Field R/0O/C Data
From Optional  |First date that the journal may be generated
To Optional |Last date that the journal may be generated
@ ™ [=]F3
Recurring Batch
Last Executed
Batch |CADM KSG Test 1 -
Description |This is a test T
Recurring Batch Type | Single Ledger - ; T Seplember 2024 ; T
Ledger [HARVARD UNIVERSITY — I
. AutoCopy...
Enable Security Il |1 g M T W T E 5
Journal Entry 1 2 3 4 5 6 7
= Effective Dates 8 9 10 11 122 13 14
Journal |CADM KSG Testing journal
From 15 16 17 18 19 20 21
Ledger |HARVARD UNIVERSITY
To 22 EER 24 25 26 27 28
Category |Adjustment
Currency |USD Conversion Type [ 1] 269 370 ; g 15::) _]41 15,)
U
23.56p 2024
Generate ) Cancel

6. Click File > Save (or yellow disk on the toolbar, or Ctrl-S) to save the recurring batch entered.
The recurring batch header has been saved.

1. Multiple Journal Entries can be created in a Recurring Batch by clicking on the green plus
(New) on the toolbar or using the down arrow key while the cursor is on Journal Entry:
Journal (name). The majority of users only create one journal with one batch.

Define Recurring Journal Formula Entry Lines

7. Select the Lines button

@ - ax
Recurring Batch
Last Executed
Batch (CADM KSG Test 1
- - Period
D:
escription  This is a tesf Dt
Recuring Batch Type | Single Ledger -
Ledger [HARVARD UNIVERSITY
AutoCopy.
Enable Security il h
Journal Entry
- Effective Dates
Joumnal (CADM KSG Testing journal 5
Tom
Ledger HARVARD UNIVERSITY .
o
Category |Adjustment
Currency USD Conversion Type i[h
Generate

8. The Journal Entry Lines form will pop up
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O Journal Entry Lines (HARVARD UNIVERSITY) - KSG Test 4, KSG Test 4

Line | Account

Line Description

9. Complete the following fields on the Journal Entry Line form to set up a journal line:

Field R/O/C Data

Line Required |Line Number

This field numbers the lines in the journal entry. Selecting
a number other than 1 will allow the user to add a line in
between if updating in the future.

Typing in 10 in the Line field, gives the user the ability to
add lines anywhere between 1-9.

Use consistant sequence for the next line, ie if the first
entry line is 10 the next entry line will be 20, then 30...

Account Required |Code combination to be used when the recurring journal
is generated

Line Description Optional |Description of the recurring journal entry line
Example: This is a test
O Journal Entry Lines (HARVARD UNIVERSITY) - KSG Test 4, KSG Test 4 ™ [= &3
v
Line E Account [640.58110.0012.000000.120672.0000.00000

Line Description
This is a test
Account Description

CCOR~Central Fi.CCOR*Working Ca.Cash Lockbox.Unspecified. CCORCASH SRO L.120672*Unspecif. Unspecifie | ]

e At this point, the recurring journal does not include dollar amounts.

e Continue with the next step to enter a fixed dollar amount for each time the journal is
generated.

e If the journal will have different dollar amounts each time it is used, skip the next step
to continue without dollar amounts.
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10. To add a dollar amount for the line, click in the lower section labeled “Formula”.

Fill in:
Field R/0O/C Data

Step Conditional  [Number of the step, use “1”.

Operator Conditional |Instruction to the system, use “Enter” (default).

Amount Conditional  |Add the dollar amount desired.
Example below shows the set up for a journal
line to have a $10 debit.
To use a credit amount, type a negative symbol,
for example -20 for a $20 credit.

Formula
Balance Amount
Step Operator Amount  Account Type Type [1]
1| Enter v 10| v v =

Account Description

11. To start a new line, click the green plus (New) on the toolbar or arrow down on the keyboard to

add another line to the journal. Continue to add/ fill in/saving as many lines as desired.

Window Help

8588 P

Tt

e The Page Up or page down on the keyboard may be used to move around to different
lines.

12. When all lines have been input, click File > Save (Ctrl-S or the yellow disk on the toolbar).
The system displays the message “Transaction complete: xx records applied and saved” on the
bottom left of the screen.

13. At this point, the recurring journal template has been created and saved.

e This instruction is only about creating a journal template. Continue with Generate a
Recurring Journal work instructions to generate a journal based on this template.

14. Select File > Close Form or the x in the upper right of the form(s) to exit.
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Finding a Recurring Journal Formula

After defining a recurring journal batch, it can be reviewed or edited.
This includes changing code combinations, dollar amounts, descriptions, adding and/or deleting lines.

Follow the steps below to locate a previously saved recurring journal batch for edit or review.

15. Select a HRVDAGLA... responsibility

Home

4 Bl HRVDAGLA A® Navigator - HRVDAGLA

Reports .

_ Functions | Documents
Enter Journals:Define:Recurring
Mew Journal Define recurring journal formula
Encumbrances
Allocations - Journals
HUGL - Journal Adjustment Enter

% New Journal
Allocation - Define
[~
=1 Alocation
b Em Generate Recurring
) g
b B3 Other N + Generate
= or —| — .

16. Select Journals > Define > Recurring
This will open the Define Recurring Journal Formula form:

O Define Recurring Journal Formula (HARVARD UNIVERSITY)

Recurring Batch
Last Executed
Period
Date

Batch |
Description
Recurring Batch Type |Single Ledger -
Ledger |HARVARD UNIVERSITY

A AutaCopy
Enable Security il

Journal Entry
Effective Dates
From
To

Journal
Ledger
Category

Currency Conversion Type I/

Lines

Generate

1. Please be mindful of other users’ recurring journals and refrain from editing them

17. There are multiple methods to find an existing recurring batch. Each one is explained in the

steps below.
e Tool Bar
e Keyboard

e Menu Bar
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18. Tool Bar
e Select the Batch field and click on the Flashlight icon above

L - e

4ol Y Y IR IV Y XK

O Define Recurring Journal Formula (HARVARD UNIVERSITY)

Recurring Batch

| Batch Last Executed
‘a‘c Period
Description ‘ T
Recurring Batch Type | Single Ledger =
Ledger |HARVARD UNIVERSITY
AutoCopy...

Enable Security L1

e This will generate a list of recurring batches
e Select the journal batch desired

19. Keyboard
e Place the cursor in the Batch (Name) field, use shortcut key F11 to entry query mode

O Define Recurring Journal Formula (HARVARD UNIVERSITY)

Recurring Batch

Last Executed
Batch |

i Period
Description Date
Recurring Batch Type -
Ledger
AutoCopy. ]
Enable Security i h B —
Journal Entry
Effective Dates
Joumnal
From
Led,
sdger o
Category
Currency Conversion Type il h
Generate

e Add search criteria to the form (% = wildcard) and select Ctrl + F11 to run the search

O Define Recurring Journal Formula (HARVARD UNIVERSITY) M = B3

Recurring Batch

Last Executed
| Batch |KSG%| |

. Period
Description Dale
Recurring Batch Type ~
Ledger
AutoCopy
Enable Security il h
Journal Entry
Effective Dates
Journal
From
Led
edger T
Category
Currency Conversion Type il
Generate

e If there are multiple results, page down or down arrow on the keyboard to review.
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20. Menu Bar

e Select the Batch field

HY0 0586 % EE AB0DE 2

O Define Recurring Journal Formula (HARVARD UNIVERSITY)

Recuriing Batch
— Period
D ot
escription Date
Recurring Batch Type | Single Ledger -
Led ARV,
edger [HARVARD UNIVERSITY T )
[/ Enable Security ({5} —_—————
Journal Entry
Effective Dates
Journal
From
Ledger g
Category
Currency Conversion Type ()]
Generate

e C(Click View > Query by Example> Enter to enter query mode

: Folder Tools Window Help

Show Navigator

I Zoom

i Find...
Find All

€ D

ula (HARVARD UNIVERSI

Record » Bun

Cancel
Translations

Show st Criteria
Attachments... Show Last Criteria

Count Matching Records

Summary/Detail

% Requests

e Add search criteria information relevant to the batch name to the form (% = wildcard) If

>

Example used in screenshot below: KSG%

O Define Recurring Journal Formula (HARVARD UNIVERSITY)

Recurring Batch
Last Executed
I Batch |KSG%| .
Period
Descripti
escription B
Recurring Batch Type v
Ledger
g AutaCopy..
Enable Security il h
Journal Entry
Effective Dates
Journal
From
Ledger To
Category
Currency Conversion Type (1)}
Generate
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e Select View > Query by Example > Run to execute the query

WETR Folder Tools Window Help

Naigator BB 08 DB e

i Query By Example Entel
— , R
Cancel

Show Last Criteria
Count Matching Records

Aftachments...

Rei

Requests ‘

e This will bring up the first batch which meets the criteria entered
e Toview more batches that meet the same criteria, click the down arrow or the page
down key on the keyboard

21. At this point, the recurring journal batch formula is found and can be edited as desired using the
information previously given in this work instruction.

At any time, if a change is made accidentally, exit without saving the recurring journal form and
start again

22. Select File > Close Form or the x in the upper right of the form(s) to exit.

Questions?

If you have any questions, please contact the HUIT Support Center at 617-495-7777, or via email at
ithelp@harvard.edu.
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